Now, if we have \( z^3 = -pz + q \), the rule, attributed by Cardan\(^1\) to Cipio Ferreus, gives us the root

\[
\sqrt[3]{\frac{1}{2}q + \sqrt{\frac{1}{4}q^2 + \frac{1}{27}p^3}} - \sqrt[3]{\frac{1}{2}q + \sqrt{\frac{1}{4}q^2 + \frac{1}{27}p^3}}
\]

Similarly, when we have \( z^3 = +pz + q \) where the square of half the last term is greater than the cube of one-third the coefficient of the next but one term, the corresponding root is

\[
\sqrt[3]{\frac{1}{2}q + \sqrt{\frac{1}{4}q^2 - \frac{1}{27}p^3}}
\]

It is now clear that all cubic equations can be reduced without the use of trigonometric sections except for the solution of certain known quantities, which provide two mean proportional between such a quantity and one-third the known quantity \( p \). Then take \( NP = \frac{3q}{p} \), that is such that \( NP \) is to \( q \), the other known

---

J. Robert Cooke
E. Ted Sobel
Demonstration Package
Welcome to the MathWriter™ 2.0 Demonstration Package!

I think [the authors] are to be congratulated for the fantastic job that they have done with both the program and the manual. . . . The version of MathWriter that I tested is well-designed and is full of innovative ideas that others would do well to emulate. . . . I am impressed with how well the features of a math editor have been integrated with the features of a more general word processor. The use of math structures wildcards in the Find/Replace dialog comes to mind as one such example. . . . The extensive capabilities of MathWriter are very well integrated and there is a consistency throughout the program that lowers the learning curve for new users because many actions make sense and seem natural. . . . This new version of MathWriter is a real winner.

MathWriter is especially useful as a scientific word processor. I am very impressed with the capabilities of MathWriter. It is the first scientific word processor which captures the philosophy of the Macintosh interface. It is easy to use: you see what you type and you don’t need to learn any complicated new language. In a couple of hours I was able to write my own documents with all types of equations.

Javier Cabrera
Rutgers University

Benton Leong
Symbolic Computation Group
University of Waterloo

This Demonstration Package contains two disks—a Program Disk and a second disk with Demonstration Files. The copy of MathWriter 2.0 included here is a virtually complete working version, but code has been removed to make it unusable for productive purposes. With this Demo Version, you will be able to create new documents or open documents created by working versions of MathWriter 2.0 (Professional or Educational), but you will not be able to save any of these files for later use. In addition, all cut-and-paste features have been removed, as have the spell-checker, thesaurus, and hyphenation feature. Printed output is also restricted, with randomly selected lines truncated on each page.

To start this Demo Version of MathWriter 2.0, copy the files on both disks onto your hard drive and double-click on the MathWriter program icon. If your system consists of two floppy disk drives, place your Macintosh® system disk in one drive and the Program Disk in the other drive. You will need to swap disks a few times before the three files on the second disk are loaded into your computer’s memory.

The Guided Tour, which is opened from within the application, provides an introduction to the many powerful features of MathWriter, also described on the following pages in this booklet. The LIB.Demo file is used to show how the Library provides rapid entry of repeatedly used material. This feature is especially useful for creating complex mathematical expressions. About MathWriter™ 2.0 is a HyperCard® stack that offers another look at this innovative and powerful word processor. Click on “buttons” on the screen to go through the descriptions of MathWriter features. The third card serves as a main menu for branching to specific topics. At any point you can return to this card by clicking the Main Menu button at the top right corner of the screen. Click the Index button just below the Main Menu button to see an alphabetical list of topics, or click one of the ten topics on the main menu. To reveal the transparent rectangular buttons or “hot spots” on any screen, press command option. Type command q or click the Quit button on the main menu card to terminate the tour and leave the stack.

An order form is included at the back of this booklet to make it more convenient for you to obtain your personal copy of this powerful program. For information on site licenses, contact Software Support at Brooks/Cole Publishing Company by telephone (408-373-0728), fax (408-375-6414), or e-mail (D2248@Applelink.Apple.COM).
MathWriter
The Scientific Word Processor for the Macintosh®
Version 2.0
Demonstration Package

J. Robert Cooke
E. Ted Sobel

Brooks Cole Publishing Company
Pacific Grove, California
Brief Tour of the MathWriter Demo

We assume that you are already familiar with at least one Macintosh word processor so these instructions are brief and focus on tasks unique to technical writing. To keep the demonstration a reasonable length, many features are not shown. Some of the features described here are not included in the Educational Version; the differences between the two versions are described at the end of this document. If you wish to increase the speed of MathWriter, use the Control Panel to turn off color.

The MathWriter Interface

• MathWriter introduces new tools that permit you to compose your scientific manuscripts at the keyboard. These tools allow you to focus on substance rather than form. MathWriter was designed especially for authors of scientific manuscripts!

• By continuously displaying all the information you enter, MathWriter's highly visual interface decreases your learning time and improves your productivity.

• MathWriter enables you to create and edit mathematical expressions within a document as easily as text.

• Powerful input aids expedite the frequent changes in fonts, font sizes, font styles, and vertical placement of characters and special symbols within mathematical expressions common in technical manuscripts.

• Revision tracking automatically marks and displays the contents of additions and deletions within the document, supplementing markers in the margin.

• All editing is performed within the document window. You need not move into separate windows to edit headers, footers, footnotes, mathematical expressions, text, or even sidebars.

• This already powerful word processor provides a path for growth through modules. The MathWriter Modules™ behave as smart desk accessories: Modules can access the document directly without using the Clipboard and can utilize code within the MathWriter host to perform tasks. For example, a database module or test-generation module can be linked to and become an integral part of MathWriter.

Basic features

Click in the scroll arrows to move a few lines, or press option when you click the scroll arrow to scroll a single line. This speed scrolling is especially useful when multi-line mathematical expressions are present. The cursor changes shape when you move it from one work space to another work space. For example, if you move the insertion point into the header, click, and then return to the main body, the cursor changes to and then back to .
Use Show Layout on the Format menu to display the boundary lines for the margins, the header, and the footer. Use Show Ruler on the Format menu to display the Ruler at the top of the document window. It displays the settings for the paragraph that contains the blinking insertion point.

For an overview of the appearance of this multipage document, select Overview from the File menu. Drag the small square “handle” at the bottom-right corner of the first portrait to make the portraits larger or smaller. If you cannot view all pages at once, use the scroll bar to bring others into view. Click the square close-box in the top-left corner of the window to close this window.

---

**Revising a Manuscript**

Word processors contribute a great deal to the task of perfecting a manuscript. In fact, this may be the most important contribution a word processor makes to the writing process.

**Spell-checker, thesaurus, and hyphenation**

The spell-checker, thesaurus, and hyphenation code is not included with this demo. MathWriter enhancements include a supplementary word list of math, science, and engineering terms and location and removal of repeated words.

**Find/Replace: locating text, styles, mathematics, and revisions**

The Find/Replace feature is quite general. You can locate and replace any string of text whether it is an embedded substring or a whole word; search and replace any font, font size, or style, regardless of the characters; and locate and replace hidden formatting characters such as the end-of-paragraph symbol or a tab marker. Because mathematical expressions are treated as text, rather than as graphics, you can also locate and replace mathematical expressions. You can even specify a search direction. As with nearly all features, you can search and replace by mouse action or keyboard commands.

**Revision tracking**

In the following example, Abraham Lincoln could have used the revision tracking feature to annotate the revisions he made before delivering his famous address at Gettysburg. In this example, strikeout-style text identifies deletions and box-style text marks additions he made to his first draft.

- Scroll through this example, select text containing an addition and a deletion, and then choose Revise Selection from the Edit menu. To mark proposed revisions, press `command option R`, make changes, AND then disable revision tracking by again pressing `command option R`. The typeface indicator in the status bar at the base of the document window contains brackets when this feature is enabled.

---

**Gettysburg Address**

*(A portion of Lincoln’s first draft as annotated)*

Four score and seven years ago our fathers brought forth, upon this continent, a new nation, conceived in Liberty, and dedicated to the proposition that all men are created equal.
Now we are engaged in a great civil war, testing whether that nation, or any nation, so conceived, and so dedicated, can long endure. We are met here on a great battle-field of that war. We have come to dedicate a portion of it as the final resting place for those who here gave their lives that that nation might live. It is altogether fitting and proper that we should do this.

**Line numbering**

MathWriter can supply line numbers on printed copies of documents as well as on the screen to expedite the editing process. To enable the line numbering feature, select Line Numbers from Doc Preferences... (File menu).

- Enable and then disable the line numbering feature.

**Input Tools**

MathWriter supports both mouse and keyboard input for most commands. By pointing and clicking the mouse, the novice or infrequent user can easily and quickly use MathWriter without having to memorize commands. On the other hand, the experienced or power user will appreciate the speed afforded by keyboard commands. Whatever your level of experience, you can mix these approaches as you wish.

**Keyboard commands for type style changes**

MathWriter has an extensive set of keyboard commands. Some that control type style changes are listed here.

**Font Selection**

- % spacebar: Toggles between the current font and the Symbol font (which contains the Greek alphabet and other mathematical symbols)

**Font Size Selection**

- % +: Next larger font size on size submenu
- % option +: Increase font size by one point
- % -: Next smaller font size on size submenu
- % option -: Decrease font size by one point

**Font Style**

- % P: Plain (and removes all other style attributes)
- % B: Bold
- % I: Italic
- % U: Underline
- % Y: Other styles (access to numerous other styles)

**Font, Size, Style, Justification, Alignment**

- % \: Revert to immediately previous style
- % <: Style 1 of user-selected attributes
- % >: Style 2 of user-selected attributes (Use Doc Preferences... in the File menu to assign user-selected attributes.)

**Online help**

The online help, not included here because of disk space limitations, is accessed from the Windows menu.
Palettes and Diac menus

The Palettes and Diacriticals menus are always available. Palettes provides mouse access to the characters of the Symbol font (except the Greek alphabet, which is available from the Palettes window), a few special characters, and the Variables. As you drag the cursor over the Palettes menu, your current choice appears on the bottom row. When you release the button, the selected character is typed at the insertion point. Frequently used rows can be placed at the bottom of the screen.

Special variables are included for reporting creation date, current date (which you can use in a default file to obtain the current date automatically), creation time, current time, page number, and total number of pages (which can appear only in headers and footers), footnotes and cross-references to footnotes, equation numbers, subequation numbers, textual cross-reference to an equation, any number of sets of user-defined variables analogous to equation numbering, and document file name. You can use these variables to automatically number figures, tables, paragraphs, and so on. The file name variable allows you to insert the name of the file into the text automatically, so you can more easily maintain the correspondence between printed output and the MathWriter file used to print it. [Equation numbering is demonstrated on p. 9.]

You can use the Diac menu to add a diacritical mark to any character in this paragraph when the insertion point is immediately to the right of some alphabetic character. The horizontal grouping symbols are available only when you have selected one or more characters.

Floating windows: Templates, Palettes, Tools, Font Table, and Library

The floating windows can be selected from the Windows menu. The templates menu at the left of the screen provides easy access to self-formatting mathematical expressions. The Tools window at the bottom right-hand of the screen provides mouse access to the four editors; the Tools submenu of the Windows menu shows the keyboard equivalents. The icons are arranged in the pattern of the keyboard equivalents. The I-beam selects the text editor, the split I-beam selects the math editor (which is used to edit within a built-up mathematical expression), the plus icon selects the sidebar editor, and the arrow selects the character editor.

Library

The Library provides rapid entry by mouse or by keyboard of repeatedly used material. Library entries can be up to 32K in size and may consist of text, graphics, or mathematical expressions. You may create specialized libraries for various tasks and have MathWriter search multiple open libraries. Use the mouse to double-click on an entry in the Library window to select it, or use the keyboard to type the abbreviated name followed by a space for immediate substitution. A type-ahead buffer permits continuous input.

To illustrate this feature, select Library Window from the Window menu. Use Open... on the Library submenu of the Windows menu
to gain access to LIB.Demo. This displays the Library window that can float above and remain available to your document. Type “\textbackslash qe” (backslash lowercase “q” and “e” and spacebar, or double-click on the expression in the Library window to insert the entry at the insertion point.

\[ y = ax^2 + bx + c \]

To add an entry, create it in the document window, select it, and use New Entry From Selection from the submenu of the Library command on the Windows menu.

**User-defined style attributes**

Usually when typing a technical manuscript, you need to change style attributes frequently. To make this task simpler, MathWriter allows you to define two typeface combinations using the Doc Preferences command on the File menu. You can access these combinations with mouse or keyboard and rapidly change font, font size, font style, alignment, and line spacing.

**User styles**

User Styles on the Style menu allows for rapid formatting and ensures consistency of style among the various levels of headings, figures, captions, and so on. The named combinations you create are listed at the end of the Style menu. If you subsequently modify the definitions, MathWriter automatically implements the changes throughout the document.

**Auto save and Auto Backup**

You can automatically save the current version of a file and its most recent older version using choices from the Doc Preferences command on the File menu.

**Graphics and Sidebars**

MathWriter supports the mixing of graphics such as pictures and figures with text. It can also import mathematical expressions as graphics, but a far more powerful approach to writing mathematics is described below. In addition to handling traditional bitmapped and PICT file types such as those created by MacPaint® and MacDraw®, MathWriter can also handle Encapsulated PostScript® files such as those created by Adobe Illustrator® or Mathematica®. MathWriter can resize, crop, and position these graphics. It treats a graphic as a tall character within a line of text or isolates it from the text in a sidebar so that you can place multiple lines of text adjacent to it. A graphic can become a background picture on any or all pages. Sidebars can become, in effect, isolated minidocuments within the main document and can still be fully formatted. You can also apply various border designs and background patterns to sidebars.
Place a graphic in a line of text

The customary cut, copy, and paste operations are supported. To illustrate the character editor, select the arrow from the Tools window at the bottom right of the screen. Click to select the graphic above. Then click again on the graphic and drag it vertically up or down.

Picture sidebar

A picture sidebar contains a graphic that is isolated from the body of the main text but attached to and floating with a paragraph in the main text. Words in the main text flow around the sidebar. You can resize and crop sidebars just as you can a graphic within a line of text. Picture sidebars can have borders and a background pattern, and they can be positioned horizontally (on either side of the left or right margin).

Text sidebar

A text sidebar is an isolated minidocument within a document that is attached to and floats with a paragraph of text. The main body of text wraps around the sidebar. You can resize and crop sidebars just as you can a graphic within a line of text. Text sidebars can have borders and a background pattern.

To create a text sidebar:

1. Position the insertion point at the desired location of the sidebar. For example, place the insertion point in this paragraph.

2. Select the Sidebar Editor either by clicking the “+” on the Tools window, selecting the Sidebar Editor on the Tools submenu, or typing shift]. A new Edit menu appears.


4. With the sidebar still selected, drag one of the “handles” to resize it. Even after text has been added, you can resize the sidebar, and MathWriter automatically handles wordwrap.

5. If desired, use the Edit menu to reposition the sidebar and modify the borders.

6. Click the I-beam tool to leave the Sidebar Editor and click within the sidebar. The cursor changes when you change regions.
Mathematics

In this exercise you learn to type mathematical expressions and to number equations automatically.

Part 1: Mathematical expression editor

Preparing to write mathematics

Before we examine mathematical writing features, you need to configure the MathWriter environment for these activities. If the Templates, Palettes, and Tools floating windows are not visible, select them from the Windows menu and drag them to a convenient working location.

The Templates window behaves as if it were a vertical menu bar; press on a template category and drag to select a specific template. Alternatively, you can press command (§§) and type the row number followed by the column number of a specific template. For example, "§ 2" and "1" selects the square root. If you pause before typing the column number, the selection menu pops out to prompt you. Typing other than one of the valid numerals aborts the command.

Exercise

Use the following instructions to explore the auto-formatting templates that were used to create the equation following step four. Use the box (a text sidebar) that follows the equation as a place to experiment without disturbing this document. Position the insertion point in the box. When you want to move from the body of the document into the sidebar containing the equation, click within the box to change the cursor into an I-beam.

1. Select the root template by mouse (from the Templates pop-out menu) or by keyboard (§€ 1 and 1) from the Templates window. The insertion point is positioned to receive the argument.

2. Press % E to turn on Auto Math. This option italicizes variables and keep terms such as “sin” in roman type.

3. Type “1 + sin x”. The root symbol expands automatically.

4. Press enter (not return) to exit the root.

Create this $\sqrt{1 + \sin x}$ in the box.

Type here:

Notice that you can type in the sidebar without moving into a separate window.

If you make a mistake or wish to modify the expression, press option to obtain the split I-beam cursor § to edit within the auto-
formatting structure and click within the expression. You could also select the split I-beam from the Tools window or Tools submenu (Windows menu).

Suppose you wanted to square the sine term in the box below.

5. Click within the rectangle. The insertion point indicator on the status bar changes to “sidebar” and the cursor shape again becomes an I-beam. (You may have to click in the gray shaded area of the Palettes window to move it and see the status bar.)

Edit this $\sqrt{1 + \sin x}$ to obtain this $\sqrt{1 + \sin^2 x}$

Edit this expression. $\sqrt{1 + \sin x}$

6. *Option click* within the mathematical expression immediately after “sin.” This positions the insertion point in the square root structure.

7. Press ^ or click on the arrow [up] in the Tools window (Windows menu) pointing diagonally upwards (just below the I-beam tool) to create a superscript. This changes the vertical position of the insertion point and decreases the font size.

8. Type the exponent and press *enter* (not *return*).

9. Press *enter* to terminate the superscript entry.

Because this superscript structure is nested within the square root structure, you must press *enter* again to reach the baseline and recover the I-beam cursor of the text editor. Alternatively, you could press *return* at any point to reach the baseline immediately. This use of nested operations illustrates the general procedure for constructing a mathematical expression of any complexity.

10. Press ME to turn off Auto Math.

As a final exercise, reproduce the following table.
1. Place the blinking insertion cursor in the sidebar.

2. Use $\%$ 0 and 2 to activate the table template. Use "0" for row "10". Use \textit{return} to create a new row, \textit{tab} to create a new column, and \textit{enter} to exit the table.

The cells of a table can contain numbers, text, graphics, or mathematical expressions. Use Matrix Format... in the Format menu to change the defaults. When the insertion point is within a cell, you can insert or delete a row or column using Insert and Delete on the Edit menu.

Remember, \textit{option click} to edit within a cell. The status bar indicates the row and column of the insertion point.

\textbf{Automatic numbering}

Numbering equations and cross-referencing them in the text is an important feature for writing math. Suppose you decide to assign a number to the first equation in the sidebar below. Equation [1] then would become equation [2]. Without MathWriter's automatic numbering, you would have to find and increase all succeeding equation numbers and all cross-references to them in the text and elsewhere. MathWriter handles this task automatically. The equation

\begin{equation}
y = x^2 \quad \text{[Click and tab \rightarrow]}
\end{equation}

is a special case of the quadratic equation

\begin{equation}
ax^2 + bx + c = 0 \quad [1]
\end{equation}

\begin{equation}
x_{1,2} = \frac{-b \pm \sqrt{b^2 - 4ac}}{2a} \quad [2]
\end{equation}

This text refers to equations [1] and [2].
To add the equation number to the first equation and update the number of the following two equations and the references to them in the text, perform these steps:

1. Place the insertion point in the first equation at the tab to the right of the note "[Click and tab]."

2. Select equation number \( \Xi \) from the last row of the Palettes menu. As you drag the cursor over each icon, its name appears on the bottom row of the menu. When you release the mouse button, MathWriter automatically calculates and assigns the equation number. (Alternatively, type `command option E`.)

With Variables Format... in the Format menu you can assign such things as the variable style, format, and style of enclosing brackets for equation numbers.

Automatic numbering of other elements such as figures, tables, theorems, paragraphs, and so on is also possible. In addition, you can define sets of dynamic variables for user-defined categories and MathWriter automatically tracks them.

**Professional vs. Educational Version**

The Educational Version is a subset of the Professional Version. It is intended for authors who do not require the advanced features and who do not have access to the more powerful Macintoshes. Both versions fully support the creation and editing of mathematical expressions within the document as well as traditional word-processing features.

Use the Professional Version if you have a Mac II or an SE/30 with two Megabytes or more of RAM and a hard disk. If you have a Macintosh Plus or SE (68000-based CPUs) with only one Megabyte of memory and two disk drives, use the Educational Version.

**Features Removed**

Color, Thesaurus, Hyphenation, Math-Science-Engineering dictionary, Revision tracking, Library, Memo notes, Sidebars, Background pictures, User styles, Adjustment for some defaults, Overview, Multiple columns, Auto-italics in mathematical expressions, Tab on user-selected character, and line numbering.

**Features restricted**

Character Editor retains cropping and sizing of graphics, up to one user-defined variable allowed; Find/Replace limited to traditional character searches; no more than one modular extension can be used at a time; and no more than four documents can be opened at once.

**Summary**

MathWriter contains many new technical-writing tools. This brief summary presents some of the highlights. If your work requires these tools or if you just like MathWriter's unusual blending of simplicity with power, contact Brooks/Cole Publishing Company by phone, fax, e-mail, or regular mail listed in the About MathWriter command on the File menu to place your order.
ORDER FORM

YES! I want to order the following:


Copies/Price/$ Total

___ x $ 395.00 ______

___ x $ 99.95 ______

Subtotal ________

TAX ________ (Residents of CA, CT, CO, FL, GA, IL, IN, KY, MA, MD, MI, MIN, MO, NC, NJ, NY, OH, PA, RI, TN, TX, UT, VA, WA, WI add appropriate sales tax.)

Handling $ 2.00

TOTAL ________

Please ship to:

Name ____________________________________________

Institution ____________________________________________

Address ____________________________________________

City/State/Zip Code ____________________________

Telephone ____________________________

Purchase Order enclosed Please bill me Check or money order enclosed

Charge my VISA MasterCard American Express

Card Number ____________________________ Expiration Date ____________________ Signature ____________________

Billing Address:

Name ____________________________________________

Institution ____________________________________________

Address ____________________________________________

City/State/Zip Code ____________________________

Return to:

Brooks/Cole Publishing Company
Department JK
511 Forest Lodge Road
Pacific Grove, CA 93950

SAVE MONEY! Send payment with your order or use your credit card and Brooks/Cole will pay all postage charges for you.

Prices subject to change without notice. We will refund payment for unshipped out-of-stock titles after 120 days and for not-yet-published titles after 180 days unless an earlier date is requested in writing by you. Please allow 4 weeks for delivery.
Easy-to-use, programmable symbolic processing software for just $395!

Maple 4.2.1
Symbolic Computation for the Macintosh®
Symbolic Computation Group, University of Waterloo, Ontario, Canada

"Maple is currently used at more than 1,000 sites worldwide and boasts an impressive track record in education. It has been the primary component in the development of new calculus curricula funded by the Sloan Foundation and the National Science Foundation."
Instructional Computing Update, October 1990

Requires only one megabyte!

Put Maple's speed, reliability, and power to work on any Macintosh® — even the Mac Plus. Maple combines algebraic and numerical computation with two-dimensional graphics to give you more power per dollar than any other symbolic processing software.

Maple comes with a unique library of more than 1500 built-in functions, including operations on integers, rational numbers, polynomials, symbolic and numeric approximation, statistics, linear algebra, calculus, differential equations, and more. And Maple can be customized to reflect your research or computational needs.

No risk! Order Maple 4.2.1 on our 30-day money-back guarantee! Simply fill out the coupon below and return to Brooks/Cole along with your check or credit card number. Or call toll-free 1-800-354-9706.

**ORDER FORM**

**YES! I want to order Maple for just $395!**

(ISBN 0-534-10224-7) 

(Quantity) = ________ copies x $395

**TAX** (Residents of AL, AZ, CA, CO, CT, FL, GA, IL, IN, KS, KY, LA, MA, MD, MI, MN, MO, NC, NJ, NY, OH, PA, RI, SC, TN, TX, UT, VA, WA, WI add appropriate sales tax.)

$2.00 Handling

**TOTAL**

Please Ship To:

Name

Institution

Address

City / State / Zip Code

Telephone

Return to: Brooks/Cole Publishing Company Dept. MWMAP Phone: (408) 373-0728

SAVE MONEY! Send payment with your order or use your credit card and Brooks/Cole will pay all postage charges for you. Prices subject to change without notice. We will refund payment for unshipped out-of-stock titles after 120 days and for not-yet-published titles after 180 days unless an earlier date is requested in writing. Please allow 4 weeks for delivery. Purchase order enclosed. Please bill me.

Check or money order enclosed.

Charge my: VISA, MasterCard, American Express.

Card Number — Exp. Date

Signature

Billing Address:

Name

Institution

Address

City / State / Zip Code

Telephone

Fax: (408) 375-6416

Macintosh is a registered trademark of Apple Computer, Inc.
Technical writing — and more!
With MathWriter 2.0, technical writing has never been easier! The complete "what you see is what you get" scientific word-processing program treats mathematical expressions as self-formatting text that can be edited, rather than as imported graphics. Using MathWriter 2.0, you can edit headers, footers, footnotes, sidebars, and mathematical expressions within the document window! Available in both a Professional Version and an Educational Version, the Professional Version is suited for writing research papers, dissertations, and exams, while the Educational Version is suitable for writing undergraduate papers or high school tests.

Both versions feature:
- A spelling checker
- Automatic on-screen numbering of equations and figures and their cross-references
- Ability to import, size, and crop encapsulated PostScript®, bit-mapped, and object graphics
- Automatic line spacing and line numbering
- Both mouse and keyboard entry for nearly all commands
- Palette and Font Table for mouse entry of all symbols
- Automatic sizing and centering of mathematical expressions

The Professional Version also offers:
- Interactive libraries for substitution of frequently used text, mathematical expressions, or graphics
- Text and graphics sidebars that act as minidocuments with automatic word wrap
- A supplementary math-science-engineering dictionary, a thesaurus, and hyphenation control
- Automatic italics for variables
- Tracking of proposed additions and deletions for collaborative writing

System Requirements
Macintosh® SE/30 or Macintosh II family with two megabytes of RAM and a hard disk. MathWriter will run on machines with only one megabyte, but document size will be limited.